Tools / BS Exporter for Blender


Quick Start Guide


[ return to overview ]


  1. Download and install Blender for your platform
  2. Download the BS Exporter for Blender
  3. Extract the zip archive to <your blender install folder>/.blender/scripts/

To experience your exported Blender scenes, download and install BS Contact VRML/X3D.


The BS Exporter for Blender requires a working version of Blender 2.37a or higher. BS Contact VRML/X3D is available for the Microsoft Windows platform.


How to export

You can export your Blender scene to the X3D format using the menu "File > Export > BS Exporter for Blender (.wrl .x3d)...". The same option is also available from the "Scripts" window.

Exporting VRML/ X3D from File menu
Exporting VRML/ X3D from the "File" menu

Exporting VRML/ X3D from Scripts window
Exporting VRML/ X3D from the "Scripts" window


Export dialog options

Once the exporter is launched, a dialog options window appears. In most cases, the default options should be adequate.

Dialog Option Description
Export to Press the "..." button to specify an alternate path and file name. The default is the path and file name of the original saved Blender (.blend) file, but with the relevant Web3D file extension appended (.x3d, .x3dz, .wrl or .wrz)
Export as Select either XML or VRML encoding. Default is XML. XML encoding results in a file extension of .x3d or .x3dz and VRML encoding results in file extensions of .wrl or .wrz.
Use Gzip Compression If you don't intend hand-editing the exported code, then compression is recommended. Default is off (export uncompressed files).
Copy Textures to Subfolder Specify a folder for textures to be copied to by pressing the "Set" button. Default is on with a subfolder of "tex".
Export Normals or Smooth Angle Default is Export Normals, which produces best results under most circumstances. For detailed information see "Smoothing angle and normals".
Export Animations Default is on. For detailed information see "Animation".
Export Vertex Color Default is on. For detailed information see "Vertex colors (and radiosity)"
Digits of Precision This increases the accuracy of exported 3D models but also the file size. Default is 3.
Animation Precision This increases the accuracy and smoothness of exported animations but also the file size. Default is 2. For detailed information see "Animation".
Author and Scene Title Optionally specify an author and title by pressing the respective "Set" button. This text is exported as XML meta data or VRML comments.


Support and help

lf you require support in developing content for BS Contact VRML/X3D or help with the exporter you'll find some links within Blender's Help menu. Here are the links to the support areas of the Bitmanagement website:


External links

If you need help with using Blender itself, please check the links below.

Don't forget to check out the "Hotkey and Mouse Action Reference" from Blender's Help menu.


[ return to top | return to overview ]

© 2002 - 2013 Bitmanagement Software - All rights reserved.